Search Medicare Blog
Recent Comments

Some states have chosen to expand Medicaid under the Affordable Care Act to low-income adults under age 65. In these states, some people who might previously have qualified for Medicaid under a medically needy program may now qualify more easily, under the terms of the state’s Medicaid expansion. However, Medicaid expansion does not affect those who are 65 or older. Because the elderly often have significant medical expenses in the form of long-term care costs, medically needy programs remain important for them.

Leave a Reply

Contact Us | Privacy Statement